W3C home > Mailing lists > Public > www-validator-cvs@w3.org > September 2009

[Bug 7729] New: input type image validation error against value attribute

From: <bugzilla@wiggum.w3.org>
Date: Fri, 25 Sep 2009 20:51:58 +0000
To: www-validator-cvs@w3.org
Message-ID: <bug-7729-169@http.www.w3.org/Bugs/Public/>

           Summary: input type image validation error against value
           Product: Validator
           Version: HEAD
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HTML5
        AssignedTo: dave.null@w3.org
        ReportedBy: kevinpeno@gmail.com
         QAContact: www-validator-cvs@w3.org

<input type="image" name="submit" value="submit" src="/images/ui-login.png"

This should be invalid against HTML5 because it contains the value attribute.
This works properly. HOWEVER, the follow also fails:

<input type="image" name="submit" src="/images/ui-login.png" class="submit"/>

the error given is:
"Required attributes missing on element input."

Error #2 does not conform with
http://www.whatwg.org/specs/web-apps/current-work/#image-button-state which
states under "bookkeeping details" that: "The element's value attribute must be

Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 25 September 2009 20:52:11 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:17:39 UTC