W3C home > Mailing lists > Public > www-validator-cvs@w3.org > August 2008

[Bug 6004] New: Unhandled error in API

From: <bugzilla@wiggum.w3.org>
Date: Sun, 31 Aug 2008 00:12:26 +0000
To: www-validator-cvs@w3.org
Message-ID: <bug-6004-169@http.www.w3.org/Bugs/Public/>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=6004

           Summary: Unhandled error in API
           Product: Validator
           Version: HEAD
          Platform: PC
               URL: http://validator.w3.org/check?uri=http%3A%2F%2Fwww.katoo
                    mbamotel.com%2F&charset=%28detect+automatically%29&docty
                    pe=Inline&group=0
        OS/Version: Windows XP
            Status: NEW
          Severity: major
          Priority: P2
         Component: Parser
        AssignedTo: dave.null@w3.org
        ReportedBy: taco.fleur@clickfind.com.au
         QAContact: www-validator-cvs@w3.org


Sorry if this is not the right place to report this. This bug is in relation to
the API, but I could not find a specific project to report this to.

We're integrating with W3C validator on www.clickfind.com.au and are receiving
error through the API that are not handled.

The error we are getting is as following
<h1>Software error:</h1> <pre>Can't use an undefined value as an ARRAY
reference at /usr/local/validator/httpd/cgi-bin/check line 2018. </pre> <p> For
help, please send mail to the webmaster (<a href="mailto:[no address
given]">[no address given]</a>), giving this error message and the time and
date of the error. </p>

The URL we used to check is as following

http://validator.w3.org/check?uri=http%3A%2F%2Fwww.katoombamotel.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

I'm guessing the error should have been included in the XML that is returned by
the REST call.


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Sunday, 31 August 2008 00:13:03 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:17:33 UTC