W3C home > Mailing lists > Public > www-validator-css@w3.org > January 2010

Re: background-color parse error

From: Yves Lafon <ylafon@w3.org>
Date: Mon, 18 Jan 2010 05:05:29 -0500 (EST)
To: trevor wencl <trevor@fourfour.com>
cc: www-validator-css@w3.org
Message-ID: <alpine.DEB.1.10.1001180504410.22210@wnl.j3.bet>
On Sat, 16 Jan 2010, trevor wencl wrote:

> Ever since yesterday it appears that your API has been choking on
> background-color. Sending something as simple as:
>
> h1 { color: #F00; background-color: #F00; }

It works for CSS21 (ie: the default setting), CSS3, but not CSS2, I'll 
check that soon.
Thanks for reporting.

>
> results in an a Parse Error and it doesn't matter what the output type is.
>
> Example:
> http://jigsaw.w3.org/css-validator/validator?text=h1+%7B+color%3A+%23F00%3B+background-color%3A+%23F00%3B+%7D&warning=0&profile=css2&output=soap12
>
>
> via html
> :
> Value Error : background-color<http://www.w3.org/TR/REC-CSS2/colors.html#propdef-background-color>Parse
> Error [empty
> string]
>
> via text:
>
> Line : 1 h1
>       (Value Error : background-color
> (http://www.w3.org/TR/REC-CSS2/colors.html#propdef-background-color))
>       Parse Error
>
>
> via soap12
>
> Value Error :  background-color (
> http://www.w3.org/TR/REC-CSS2/colors.html#propdef-background-color)
>
>                                Parse Error
>
>
> The only thing I can find that comes close to relating is your faq for "Why
> does the validator complain You have no background-color with your color?"
> but that doesn't seem to have any bearing on this. It appears as thought the
> api is just choking on all "background-color" since yesterday. Please help.
> I have an app that relies on this.
>
> Thanks,
> Trevor
>
>

-- 
Baroula que barouleras, au tiéu toujou t'entourneras.

         ~~Yves
Received on Monday, 18 January 2010 10:05:31 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 27 June 2012 00:14:25 GMT