W3C home > Mailing lists > Public > www-validator-css@w3.org > January 2002

votre fragment de html

From: Annie Dubé <ann.du@sympatico.ca>
Date: Tue, 22 Jan 2002 00:41:50 -0500
Message-ID: <02a301c1a307$7d5c8b00$4dc85c41@hppav>
To: <www-validator-css@w3.org>
Bonjour,

Je désire vous signaler un problème que j'ai rencontré avec votre test de
validation.

Pour commencer, j'ai passé avec succès le test de validation de W3C XHTML.
Par la suite, j'ai fait le test avec W3C CSS et j'ai éliminé toutes mes
erreurs.

Ensuite, j'ai posé les fragments de HTML que vous donnez afin d'afficher
votre icone sur ma page web.

C'est juste après ça que j'ai rencontré mon problème : avec votre HTML, le
test de validation du XHTML me signale des erreurs : 1) Vous omettez de
fermer le tag de l'image   avec ceci :    />     et aussi, vous mettez un
border=0 dans la balise img.

Bon, pour tout vous dire, ça ne me cause pas de réel problème, puisque j'ai
mis la main dans vos codes et corrigé votre erreur. C'est juste que c'est
étrange et que je me pose des questions....

Je me demande pourquoi vous fournisez des codes comme ceux-là alors que vous
écrivez ceci :
« Pour fonctionner comme prévu, votre feuille de style CSS doit avoir un
arbre grammatical correct, cela implique que vous devriez utiliser de l'HTML
valide.»

Et vous ? Si votre HTML n'est pas valide, est-ce parce que vous n'utilisez
pas de CSS ?  Je me demande bien pourquoi....

voici la copie de votre html :


<p>
 <a href="http://jigsaw.w3.org/css-validator/">
  <img style="border:0;width:88px;height:31px"
       src="http://jigsaw.w3.org/css-validator/images/vcss"
       alt="Valid CSS!">
 </a>
</p>

merci beaucoup

a.
Received on Tuesday, 22 January 2002 00:44:10 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 5 February 2014 07:19:09 UTC