W3C home > Mailing lists > Public > www-validator-css@w3.org > October 2001

W3C CSS Validator Query

From: Philip Williamson <pnwilliamson@hotmail.com>
Date: Thu, 04 Oct 2001 14:30:46 -0700
To: www-validator-css@w3.org
Message-ID: <F134LbtjZuCSvAuF0M000013158@hotmail.com>
Hello -

I've been trying to validate my site's CSS with your validator and I'm 
running into some problems that I hope you can help me with.  My apologies 
in advance if you're not in a position to answer queries of this kind.

First, when I attemp to validate the file
(http://www.ventanawilderness.org/vwatheme.css) by URI I get the following 
error message:

I/O Error: Unknown mime type : text/plain as though the validator doesn't 
recognize the file as a CSS file.

Second, when I attempt to validate the file via upload from my hard drive, 
it does not validate; which would be fine, if I was told *why* it does not 
validate.  I get a series of level-1 warnings about having no 
background-color properties, but this does not seem to be the problem, since 
when as an experiment I tried validating your own CSS 
(http://jigsaw.w3.org/css-validator/style/general.css) the validator gives 
the same warnings, but the CSS validates.

All my CSS statements seem to check individually as valid, and I get no 
error indications, and in going through the CSS2 spec I can't find anything 
to explain the situation.  I thought the comments in the CSS might be 
screwing things up, so I created a version without them
(http://www.ventanawilderness.org/vwatheme2.css) but it's the same deal.

What I am I doing wrong here?

Many thanks,

Philip Williamson
pnwilliamson@hotmail.com






_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
Received on Thursday, 4 October 2001 17:31:17 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 27 June 2012 00:14:01 GMT