W3C home > Mailing lists > Public > www-svg@w3.org > May 2005

Re: SVG12: getPresentation* naming

From: Dean Jackson <dean@w3.org>
Date: Fri, 20 May 2005 04:30:22 -0400
To: Bjoern Hoehrmann <derhoermi@gmx.net>
Cc: www-svg@w3.org
Message-ID: <20050520083022.GL31287@homer.w3.org>

On Mon 18 Apr 2005, Bjoern Hoehrmann wrote:

> Dear Scalable Vector Graphics Working Group,
>   In http://www.w3.org/TR/2005/WD-SVGMobile12-20050413/svgudom.html the
> proposed getPresentation* methods are poorly named. The names are much
> too long and inconsistent with SVG 1.1 where getPresentationAttribute
> behave very different from the proposed methods, and with SVGAnimated*
> interfaces which have a animVal attribute rather than presVal. Please
> change the names of these operations to something much shorter and more
> consistent with SVG 1.1. Possible naming would be getAnim* but that de-
> pends on what value these operations return in SVG "Full" as I wrote in
> another comment.

We discussed this and decided to keep the current names. We prefer
descriptive names over shorter, less clear names. Also, the animVal
attribute has caused a lot of confusion over the past few years.

So, sorry, but we're going to reject this. Bjoern 100 - SVG WG 1 :)
Received on Friday, 20 May 2005 08:30:27 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 March 2017 09:47:03 UTC