W3C home > Mailing lists > Public > www-svg@w3.org > April 2005

SVG12: getPresentation* naming

From: Bjoern Hoehrmann <derhoermi@gmx.net>
Date: Mon, 18 Apr 2005 00:59:20 +0200
To: www-svg@w3.org
Message-ID: <4332e9bf.138321156@smtp.bjoern.hoehrmann.de>

Dear Scalable Vector Graphics Working Group,

  In http://www.w3.org/TR/2005/WD-SVGMobile12-20050413/svgudom.html the
proposed getPresentation* methods are poorly named. The names are much
too long and inconsistent with SVG 1.1 where getPresentationAttribute
behave very different from the proposed methods, and with SVGAnimated*
interfaces which have a animVal attribute rather than presVal. Please
change the names of these operations to something much shorter and more
consistent with SVG 1.1. Possible naming would be getAnim* but that de-
pends on what value these operations return in SVG "Full" as I wrote in
another comment.

Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de
Weinh. Str. 22 · Telefon: +49(0)621/4309674 · http://www.bjoernsworld.de
68309 Mannheim · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/ 
Received on Sunday, 17 April 2005 22:58:53 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 March 2017 09:47:02 UTC