W3C home > Mailing lists > Public > www-svg@w3.org > October 2001

RE: embed svg in html (possible bug in Adobe SVG Plugin RC1)

From: <ronan@roasp.com>
Date: Thu, 11 Oct 2001 12:23:20 +0200
To: <ronan@roasp.com>, "Uzma Shaffi" <u.shaffi@har.mrc.ac.uk>, <www-svg@w3.org>
Message-ID: <EMENJCDHGFFGOCDJOBLMGEOOCFAA.ronan@roasp.com>
I've noticed with the latest plug-in that the plug-in eventually draws the
image, but takes forever the first time the image is drawn. After that
initial delay, regeneration of the image takes place at normal speed.

Seems to be a bug in that release -----Original Message-----
From: www-svg-request@w3.org [mailto:www-svg-request@w3.org]On Behalf Of
ronan@roasp.com
Sent: Thursday, October 11, 2001 12:14 PM
To: Uzma Shaffi; www-svg@w3.org
Subject: RE: embed svg in html


  I stand corrected.

  It may not be your method but your browser giving problems at the client
end.

  I've got the latest version of the plug-in on a machine and an older
version on another. It seems that the new version has a problem with
rendering the svg I generate. That particular SVG is dynamic and has url
links to other documents, and the links show up in the drawing window, but
the rendering does not take place.

  Anybody else having this problem?

  Here is the offending site:

  http://roasp.com/cgi-bin/new_svg/examples/svgtest2.pl

  viewable in IE5 / svgexe beta 2, but not visible in NS4.7 beta 3
(candidate release).

  also,

  http://roasp.com/svg/index2.html , an html document with static and
dynamic svg in it. Same problem.

  Beware of the <object > tag. Many corporate firewalls block that tag.

  Here is my embed implementation

   <EMBED SRC="images/header.svg"
    NAME="SVG1" width="760" height="100"
    TYPE="image/svg-xml"
    PLUGINSPAGE="http://www.adobe.com/svg/viewer/install/">

   <EMBED SRC="http://roasp.com/cgi-bin/new_svg/examples/svgtest2.pl"
    NAME="SVG2" width="760" height="100"
    TYPE="image/svg-xml"
    PLUGINSPAGE="http://www.adobe.com/svg/viewer/install/">

  This seems to be the same implementation as yours





    -----Original Message-----
    From: www-svg-request@w3.org [mailto:www-svg-request@w3.org]On Behalf Of
Uzma Shaffi
    Sent: Thursday, October 11, 2001 12:05 PM
    To: www-svg@w3.org
    Subject: embed svg in html


    Hello ,
    I m using adobe plugin, and internet explorer browser.
    Im emding svg file in my servlets like this:

    out.println("<embed  width=\""+Integer.toString(maxX)+"\"
height=\""+Integer.toString(maxY)+"\"
src=\"http://www.dev.mgu.har.mrc.ac.uk/svgfiles/map"+zoomRange+".svg\"
TYPE=\"image/svg-xml\"
pluginspage=\"http://www.adobe.com/svg/viewer/install/\"></div>");

    this code comes in <body> of the html.

    how can I use OBJECT in it???

    thanks
    uzma
Received on Thursday, 11 October 2001 06:24:37 GMT

This archive was generated by hypermail 2.3.1 : Friday, 8 March 2013 15:54:21 GMT