W3C home > Mailing lists > Public > www-style@w3.org > November 2014

Re: [css-flexbox] Renaming flex-basis:auto for less confusion

From: Bruce Lawson <brucel@opera.com>
Date: Wed, 5 Nov 2014 12:36:31 +0000
Message-ID: <CAAFGRefq+s0qrNwQfAH409TjE2JbiFb8L0W40P4h4QD_+tuCxw@mail.gmail.com>
To: W3C WWW Style <www-style@w3.org>
It's a hard call, but on balance I agree with Chris (auto for size
lookup; content for automatic sizing). My rationale is that, while
it's natural to think of "auto" as being "automatic sizing", it can
also mean "use some algorithm", eg size lookup - and the alternative
of the more intuitively named "content' makes it marginally more
clear.

bruce (as himself, not his employer)

On 5 November 2014 08:44, Chris Mills <cmills@mozilla.com> wrote:
> My thoughts on this:
>
> I think option 2 is better (auto for size lookup; content for automatic sizing) - avoiding EVEN MORE backwards compat issues with flexbox is a good thing. And I think web devs are used to the idea of things being a little different inside flexbox anyway. One more slightly odd keyword choice ;-)
>
> Chris Mills
>    Senior tech writer || Mozilla
> developer.mozilla.org || MDN
>    cmills@mozilla.com || @chrisdavidmills
>
>
>
>
>
Received on Wednesday, 5 November 2014 12:36:58 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:26 UTC