W3C home > Mailing lists > Public > www-style@w3.org > March 2013

Re: [css-display] Naming a "display:none"-ness switch.

From: Henrik Andersson <henke@henke37.cjb.net>
Date: Tue, 05 Mar 2013 23:18:07 +0100
Message-ID: <51366F1F.4030207@henke37.cjb.net>
To: "Tab Atkins Jr." <jackalmage@gmail.com>, www-style list <www-style@w3.org>
Tab Atkins Jr. skriver:
> Recent discussion between me, fantasai, and some internal people over
> the 'display-box' property
> <http://dev.w3.org/csswg/css-display-3/#the-display-box> have led us
> to conclude that it needs to be a completely separate property, not a
> longhand of 'display'.  (Reasoning below.)  However, now we need a
> name.  We've come up with "box", "show", and "box-tree".  Better
> suggestions?
> Rationale:
> Currently the Display module makes "none"-ness a sub-property of
> 'display'.  This does what we want (gives us an independent switch for
> whether or not the box is shown, separate from box type), but this has
> some problems:
> * To set the box type safely, you need to always set two properties,
> 'display-inside' and 'display-outside', so as to avoid accidentally
> clobbering the "none"-ness value.
> * Currently, authors use 'display' to set the box type, which means
> that UA-stylesheet use of the "none"-ness value will get clobbered
> unless everyone rewrites their pages (which won't happen).

Another motivation is that it is simpler for scripting to toggle a
separate property than to remember what the old value was of the property.
Received on Tuesday, 5 March 2013 22:18:40 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:09 UTC