W3C home > Mailing lists > Public > www-style@w3.org > March 2013

Re: [css-display] Naming a "display:none"-ness switch.

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Tue, 5 Mar 2013 13:46:11 -0800
Message-ID: <CAAWBYDAUWz1w_cwXx-NEf1RA8uzBm7GAMVGYjfFq=QhF27AkAw@mail.gmail.com>
To: www-style list <www-style@w3.org>
On Tue, Mar 5, 2013 at 1:05 PM, Tab Atkins Jr. <jackalmage@gmail.com> wrote:
> Recent discussion between me, fantasai, and some internal people over
> the 'display-box' property
> <http://dev.w3.org/csswg/css-display-3/#the-display-box> have led us
> to conclude that it needs to be a completely separate property, not a
> longhand of 'display'.  (Reasoning below.)  However, now we need a
> name.  We've come up with "box", "show", and "box-tree".  Better
> suggestions?

Alan points out that it's probably valuable to know the full range of
values we expect to have for this.

There's the obvious starting values - "none" and something like
"normal" or "auto".

Then, we'll add "contents", a la the current Display draft, which
suppresses the display of the box but still displays the contents, as
if they were "hoisted" up a level in the tree.

We'll probably also want a value that suppresses the box but keeps
animations/counters/etc going.  For this value, maybe "hide"?

Received on Tuesday, 5 March 2013 21:46:57 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:09 UTC