W3C home > Mailing lists > Public > www-style@w3.org > April 2013

Re: [css-variables][naming] Renaming 'var'

From: Simon Sapin <simon.sapin@exyr.org>
Date: Sun, 14 Apr 2013 09:25:14 +0200
Message-ID: <516A59DA.1060600@exyr.org>
To: Bjoern Hoehrmann <derhoermi@gmx.net>
CC: fantasai <fantasai.lists@inkedblade.net>, "www-style@w3.org" <www-style@w3.org>
Le 14/04/2013 00:57, Bjoern Hoehrmann a crit :
> * fantasai wrote:
>> So, at Rename the Web Forward [1], Sylvain and I concluded that it
>> just might be better to use 'set-' as the prefix and 'get()' as the
>> function name instead of 'var-' and 'var()'.
>>
>> p {
>>    set-???: green;
>>    background: get(???);
>> }
>>
>> This takes us closer to "custom properties" than "variables",
>> (and has the added bonus of not being an abbreviation!)
>
> Well, `get` and `set` as used here are imperative, while CSS tries to be
> a declarative language, so this seems rather confusing to me.


I like loosing the Variable terminology, but I share Bjrns concerns. 
In particular, this is gonna be awkward:

   style.getPropertyValue('set-foo')

-- 
Simon Sapin
Received on Sunday, 14 April 2013 07:25:39 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:10 UTC