W3C home > Mailing lists > Public > www-style@w3.org > January 2012

Re: [css3-*] Review of functional syntax in CSS

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Thu, 26 Jan 2012 16:36:53 -0800
Message-ID: <CAAWBYDDJMC5ukgCHVP=ftDah1LeGW3ndMMSr_K5paG53B6r61A@mail.gmail.com>
To: Christoph Päper <christoph.paeper@crissov.de>
Cc: www-style list <www-style@w3.org>
On Thu, Jan 26, 2012 at 11:06 AM, Christoph Päper
<christoph.paeper@crissov.de> wrote:
> Tab Atkins Jr. (2012-01-22 00:13):
>>  Moving it into the function name seems to be easy to understand, though.
> I see. Would it make sense then to leave out “round”, i.e. ‘up()’, ‘down()’ etc.?

Potentially, but that also seems possibly confusing, and doesn't match
the naming scheme of any other language I know of.  We discussed using
floor/ceil like most languages do, but I can't consistently spell ceil
correctly, so we figured round-up would be better.  ^_^

Received on Friday, 27 January 2012 00:37:44 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:38:54 UTC