W3C home > Mailing lists > Public > www-style@w3.org > September 2011

RE: [css3-flexbox] flex-pack distribute bikeshed

From: Alex Mogilevsky <alexmog@microsoft.com>
Date: Fri, 16 Sep 2011 06:11:43 +0000
To: Tab Atkins Jr. <jackalmage@gmail.com>, Ojan Vafai <ojan@chromium.org>
CC: "www-style@w3.org" <www-style@w3.org>, fantasai <fantasai.lists@inkedblade.net>
Message-ID: <D51C9E849DDD0D4EA38C2E539856928412129545@TK5EX14MBXC213.redmond.corp.microsoft.com>
± From: Tab Atkins Jr.
± Sent: Thursday, September 15, 2011 2:48 PM
± 
± distribute:
± +---------------------------+
± |button     button     input|
± |button               button|
± +---------------------------+
± 
± I mean, neither one's very great, but the justify seems *really* bad here.  The distribute case 
± looks way better when the last line has more than two entries in it:
± 
± justify:
± +--------------------------------------------------------+
± |button    button    button    button    button    button|
± |button button button button                             |
± +--------------------------------------------------------+
± 
± distribute:
± +--------------------------------------------------------+
± |button    button    button    button    button    button|
± |button           button          button           button|
± +--------------------------------------------------------+
± 
± I think justify is just *horrid* here.  Ideally you'd like it to look something like this:
± 
± flexgrid:
± +--------------------------------------------------------+
± |button    button    button    button    button    button|
± |button    button    button    button                    |
± +--------------------------------------------------------+
± 
± (We're debating behavior at this point, not naming.  We can use the 'distribute' behavior and 
± call it 'justify', or vice versa.)

This thread was confusing for me from the start. I first thought it is just about the name, but then there is a functional difference, defined I am not sure where...

Of the options mentioned the one marked "distribute" makes more sense (it seems we are generally in agreement on that). Whatever it ends up doing though, for me personally "justify" seems a more natural naming - what I would try if I don't quire remember the syntax.

Alex
Received on Friday, 16 September 2011 06:12:20 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:44 GMT