W3C home > Mailing lists > Public > www-style@w3.org > February 2011

Re: in-between values

From: timeless <timeless@gmail.com>
Date: Sun, 6 Feb 2011 17:54:13 +0200
Message-ID: <AANLkTimhwZS9y0aY+OfU=61CE6imswD7dSmCLXdQiac8@mail.gmail.com>
To: "Tab Atkins Jr." <jackalmage@gmail.com>
Cc: Brad Kemper <brad.kemper@gmail.com>, Simon Fraser <smfr@me.com>, www-style list <www-style@w3.org>
On Wed, Feb 2, 2011 at 5:58 AM, Tab Atkins Jr. <jackalmage@gmail.com> wrote:
>>> blend() might be a better name.

> They're both better than my idea of interpolate(), so whatever.  ^_^

i'd favor blend() over mid().

Yes i noted that mid$() allows for subsetting, but it really is for a
subset not a point, outside of that instance, i really think of it as
the halfway point which is why i went out to find another possible
meaning. Note that if you don't specify an end with mid$() the default
selects the entire set from your specified <start> to the end.
Received on Sunday, 6 February 2011 15:54:45 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:37 GMT