W3C home > Mailing lists > Public > www-style@w3.org > August 2011

RE: [css3-regions] content:flow-from() vs. flow-from

From: Alex Mogilevsky <alexmog@microsoft.com>
Date: Thu, 11 Aug 2011 07:16:08 +0000
To: Tab Atkins Jr. <jackalmage@gmail.com>
CC: "www-style@w3.org" <www-style@w3.org>
Message-ID: <D51C9E849DDD0D4EA38C2E5398569284120ECD4C@TK5EX14MBXC218.redmond.corp.microsoft.com>
± From: Tab Atkins Jr. [mailto:jackalmage@gmail.com] 
± Sent: Wednesday, August 10, 2011 4:29 PM
± To: Alex Mogilevsky
± Cc: www-style@w3.org
± Subject: Re: [css3-regions] content:flow-from() vs. flow-from
± 
± On Wed, Aug 10, 2011 at 4:19 PM, Alex Mogilevsky <alexmog@microsoft.com> wrote:
± > Somebody (Tantek?) have mentioned "display-role" or "layout-role".
± 
± Back in the day, display was split in the Template Layout module into "display-role" and 
± "display-model" (corresponding respectively to -outside and -inside).  The names make sense 
± when you think about them, but a lot of people still found them confusing, and couldn't 
± remember which did what.

For discoverability, it makes sense to have 'display' prefix. For semantics, the meaning of inside and outside is so different that it could be in totally different realms, and if you look at all the values even 'display' as shorthand may not make much sense, other than historical...

Hot about this:

	position: inline | block | absolute | fixed | table-cell | table-row | list-item | ...
	layout: text | list | table | table-row | flexbox | grid | replaced* | region

(*) replaced should probably not be a generic replace, it should be every specific kind - image | button | iframe | mathml | ...

(you may have noticed that I didn't put "position:relative" in the list. It doesn't belong there. Unfortunately it is a "position" historically, will have to be included, but really it should have been a separate property)
Received on Thursday, 11 August 2011 07:16:39 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:43 GMT