W3C home > Mailing lists > Public > www-style@w3.org > September 2010

Re: [css3-images] Linear gradients feedback

From: fantasai <fantasai.lists@inkedblade.net>
Date: Tue, 07 Sep 2010 19:59:45 -0700
Message-ID: <4C86FC21.6030406@inkedblade.net>
To: "Tab Atkins Jr." <jackalmage@gmail.com>
CC: David Singer <singer@apple.com>, Simon Fraser <smfr@me.com>, www-style list <www-style@w3.org>
On 09/07/2010 06:05 PM, Tab Atkins Jr. wrote:
> On Tue, Sep 7, 2010 at 5:41 PM, David Singer<singer@apple.com>  wrote:
>> On Sep 7, 2010, at 12:41 , Tab Atkins Jr. wrote:
>>> On Tue, Sep 7, 2010 at 12:33 PM, fantasai<fantasai.lists@inkedblade.net>  wrote:
>>>> Why aren't we using the grammar at the bottom of
>>>>   http://lists.w3.org/Archives/Public/www-style/2009Aug/0232.html
>>>> ? I think that's much more straightforward.
>>>
>>> Except for using a comma instead of "to", that's what I'm looking at
>>> right now.

And you'd rather use a comma than "to"? I think it's clearer to use "to"
since we're separating the colors with commas.

While we're at it, the use of a comma to separate the geometry from the
colors also bothers me for the same reason.

How about
   linear-gradient(<position> [to <position>]? as <color>, <color>, ...)
?

>>> We just want to split the angle case out into a separate
>>> function, and need a name for it.  I think I'll just use
>>> angle-gradient() until someone gives me something better.
>>
>> I thought I had.
>>
>> You can't contrast radial-gradient with angle-gradient, because the
>> latter is actually a linear-gradient.  And having a third called
>> linear-gradient would be even more confusing.  Which is why I suggested
>>   radial-gradient
>>   linear-box-gradient
>>  linear-angle-gradient
>> wordy as they are.
>
> It's that wordiness that makes me not particularly like them.  ^_^
> Just typing out linear-gradient() is already painfully long to me.
> And demoting just the angle gradient to a second-class citizen with a
> three-word name isn't very appealing either.

If the problem is DOM access, why not define different interfaces for
them (LinearBoxGradient and LinearAngleGradient), but leave the parsed
syntax the same?

I like dsinger's name suggestions, fwiw. If we need two different names,
I'd go with those.

~fantasai
Received on Wednesday, 8 September 2010 03:00:26 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:31 GMT