W3C home > Mailing lists > Public > www-style@w3.org > May 2010

Re: [cssom-view] addMediumListener / removeMediumListener

From: timeless <timeless@gmail.com>
Date: Mon, 31 May 2010 16:23:35 +0300
Message-ID: <AANLkTillOKIBp_Pzwfg8xx0lSeBybwmrcC-pFp1rX3GD@mail.gmail.com>
To: Anne van Kesteren <annevk@opera.com>
Cc: Simon Fraser <smfr@me.com>, Luiz Agostini <luiz.agostini@openbossa.org>, www-style@w3.org, marcosc@opera.com
On Mon, May 31, 2010 at 3:57 PM, Anne van Kesteren <annevk@opera.com> wrote:
> On Thu, 27 May 2010 17:59:32 +0200, Simon Fraser <smfr@me.com> wrote:
>>
>> It would be better to change it to matchMedia() now, rather than later,
>> since not many people are using this yet. I hope we can avoid more renames,
>> though. Or, if we accept media query lists, maybe it should just be be
>> matchQueryList(), which I think is easier to read than the awkward
>> "matchMedium". matchQuery() would also work OK.
>
> Given those I guess we should go with matchMedia / addMediaListener /
> removeMediaListener to match @media and media="" which both also accept
> media query lists.

I'd like to vote against Medium, i keep reading it and wonder what
size operation you're doing :(
Received on Monday, 31 May 2010 13:25:20 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:27 GMT