W3C home > Mailing lists > Public > www-style@w3.org > May 2010

Re: Flexbox Draft, with pictures!

From: David Hyatt <hyatt@apple.com>
Date: Tue, 25 May 2010 18:34:04 -0500
Cc: "Tab Atkins Jr." <jackalmage@gmail.com>, www-style list <www-style@w3.org>
Message-id: <EF9CF5F2-E234-411A-94F2-865D7006F052@apple.com>
To: Ojan Vafai <ojan@chromium.org>
On May 25, 2010, at 6:17 PM, Ojan Vafai wrote:

> On Tue, May 25, 2010 at 4:05 PM, David Hyatt <hyatt@apple.com> wrote:
> On May 25, 2010, at 5:58 PM, Ojan Vafai wrote:
>> On Tue, May 25, 2010 at 3:46 PM, David Hyatt <hyatt@apple.com> wrote:
>> (1) I don't think "flex" by itself is a good term for display-inside.  I also agree that "box" is arguably too generic.  You might consider just combining the words flex and box together.
>> 
>> display: flex-box
>> display: inline-flex-box
>> 
>> The same would apply to other properties, e.g., flexbox-begin not flex-begin.
>> 
>> The original version of Tab's spec used "flexbox". What's you're issue with just "flex"? flexbox seems redundant to me.
> 
> I guess my objection is more to the property names like flex-begin than to the display type.  I think it's important to distinguish between properties that apply to the container and properties that apply to children of the container.  It is the objects inside the container that actually have flex units and therefore flex.  I'd expect to see flex- in front of properties that applied to the children of a flexible box and affected flexing in some way, and not to the flexible box itself.  Once you change the properties that apply to the container to be, e.g., box or flexbox, then I'd expect the display type to have the same name for consistency.
> 
> Adding box to the property name doesn't help me to distinguish whether it happens on the box or it's children. I could just as easily read flexbox-begin as applying to this box and not it's children. :)

All the properties DO apply to the flexbox itself now except for the line breaking ones, but I think multiple lines should just be cut.  

By making flex into units and cutting all the multiple line flex stuff, all the remaining properties apply to the container only.  That's why I think flexbox is a more appropriate term than just flex.

dave
Received on Tuesday, 25 May 2010 23:34:38 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:27 GMT