W3C home > Mailing lists > Public > www-style@w3.org > May 2010

Re: Flexbox Draft, with pictures!

From: David Hyatt <hyatt@apple.com>
Date: Tue, 25 May 2010 18:05:28 -0500
Cc: "Tab Atkins Jr." <jackalmage@gmail.com>, www-style list <www-style@w3.org>
Message-id: <496527CA-CA26-4516-A851-7FE4B08B8615@apple.com>
To: Ojan Vafai <ojan@chromium.org>
On May 25, 2010, at 5:58 PM, Ojan Vafai wrote:

> On Tue, May 25, 2010 at 3:46 PM, David Hyatt <hyatt@apple.com> wrote:
> (1) I don't think "flex" by itself is a good term for display-inside.  I also agree that "box" is arguably too generic.  You might consider just combining the words flex and box together.
> 
> display: flex-box
> display: inline-flex-box
> 
> The same would apply to other properties, e.g., flexbox-begin not flex-begin.
> 
> The original version of Tab's spec used "flexbox". What's you're issue with just "flex"? flexbox seems redundant to me.

I guess my objection is more to the property names like flex-begin than to the display type.  I think it's important to distinguish between properties that apply to the container and properties that apply to children of the container.  It is the objects inside the container that actually have flex units and therefore flex.  I'd expect to see flex- in front of properties that applied to the children of a flexible box and affected flexing in some way, and not to the flexible box itself.  Once you change the properties that apply to the container to be, e.g., box or flexbox, then I'd expect the display type to have the same name for consistency.

dave
(hyatt@apple.com)
Received on Tuesday, 25 May 2010 23:06:03 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:27 GMT