W3C home > Mailing lists > Public > www-style@w3.org > August 2010

Re: [cssom-view] comments on StyleMedia interface

From: Anne van Kesteren <annevk@opera.com>
Date: Wed, 25 Aug 2010 18:09:39 +0200
To: "L. David Baron" <dbaron@dbaron.org>
Cc: "Luiz Agostini" <luiz.agostini@openbossa.org>, "Simon Fraser" <smfr@me.com>, www-style@w3.org
Message-ID: <op.vhz4idny64w2qv@g239.guest-int.opera.com>
On Wed, 18 Aug 2010 19:02:04 +0200, L. David Baron <dbaron@dbaron.org>  
wrote:
> I don't see any reason to restrict it to single queries; I'd prefer
> lists.

Lists it is. Please all review:

http://dev.w3.org/csswg/cssom-view/#the-mediaquerylist-interface


I decided to give my names one more try (now it's lists), but I can change  
them again if you do not agree with my reasoning.

matchMedia() -- compatible with how we name media="" and @media and  
shorter than matchMediaQueryList(). I suppose matchStyleMedia() could work  
too potentially.

MediaQueryList -- could not think of a better name for this.

media -- compatible with how we name media="" and @media.

matches -- compatible with the matchesSelector() proposal, and with how  
"matches" is typically used in drafts.

addListener() / removeListener() are not enforcing uniqueness.  
removeListener() therefore removes the last as there are ways you can  
notice the difference and I think this is what DOM Events does.


-- 
Anne van Kesteren
http://annevankesteren.nl/
Received on Wednesday, 25 August 2010 16:10:21 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:30 GMT