W3C home > Mailing lists > Public > www-style@w3.org > January 2008

Re: [css3-background] background-size vs background-stretch

From: Aleksey V Lazar <lazar@mnsu.edu>
Date: Fri, 18 Jan 2008 18:30:18 -0600
Message-ID: <4791449A.8090901@mnsu.edu>
To: fantasai <fantasai.lists@inkedblade.net>
CC: Anne van Kesteren <annevk@opera.com>, "www-style@w3.org" <www-style@w3.org>
hello:

fantasai wrote:
> Anne van Kesteren wrote:
>   
>> On Fri, 18 Jan 2008 21:17:37 +0100, fantasai
>> <fantasai.lists@inkedblade.net> wrote:
>>     
>>> A comment in the spec says:
>>>
>>> # Is ‘background-stretch’ a better name? People also suggested to use
>>> # ‘background-stretch: none’ instead of ‘auto’ in that case.
>>>
>>> I think we should go with 'background-stretch'. It gives a clearer
>>> idea of what the property does: background-size could be interpreted
>>> as setting the size of the background area, not the size of the image.
>>> I'd keep 'auto' as the initial value though, especially since scalable
>>> images (aspect ratio, no height/width) will always be stretched.
>>>       
> //
>   
>> we already have various background-* properties specifically for the
>> background image, such as background-position, background-repeat and
>> background-attachment so I don't think it will be interpreted as being
>> for something else.
>>     
>
> We also have background-clip and background-origin, which set parameters
> on what to interpret as the boundaries of the background area.
>
>  > I agree with David Hyatt. background-size is clearer name
>
> Web designers need terms that are more evocative even if they are less
> exact. 
As a web "designer" I disagree with the above statement.  CSS properties
should communicate their purpose and scope as clearly as possible.

> E.g. we picked 'image-position' as a name instead of
> 'replaced-element-position' even though it applies to plugins and other
> replaced elements, not just images, because it allows designers to more
> easily relate to what it means. 
I think in this case dropping "replaced-" was a good idea, but changing
"element" to "image" was not. Now this property is not as descriptive of
its scope as it could be.  I'm not at all persuaded this is easier to
understand, as the name implies it is for images only.

> I think either "background-stretch" or
> "background-resize" would be more likely to suggest the right idea than
> the current term.
>
> This is really a question for web designers, though, not for us.
>
> ~fantasai
>
>   
Aleksey

-- 
Aleksey V Lazar
Website Developer
http://www.mnsu.edu/
Received on Saturday, 19 January 2008 00:31:01 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 27 April 2009 13:54:58 GMT