W3C home > Mailing lists > Public > www-style@w3.org > September 2005

Re: Svar: Re: Request for specific changes to CSS3-UI

From: Allan Beaufour <abeaufour@novell.com>
Date: Fri, 02 Sep 2005 17:32:17 +0200
Message-Id: <43188CA3.4FB3.0046.0@novell.com>
To: <www-style@w3.org>

>>> Fre, sep 2, 2005 kl.  9:18 am skrev Daniel Glazman
<daniel.glazman@disruptive-innovations.com> i meddelelse
> Allan Beaufour wrote:
>> I've thought some more about this, and the above is what is meant in
> XForms 
>> content. It also mimics how :enabled/:disabled works for HTML
>> because that is also tied closely together with an attribute on the
>> So maybe having an :editable selector wouldn't be such a bad idea.
>> If you are designing a form, based on an editor template where you
can only 
>> edit some parts of the form, the form would have parts that are
:editable by 
>> you and some that are not. Input fields can be styled depending on
>> they will be :read- only or :read- write to the user, no matter the
>> state of the part they live in.
> Hmmm. So you mean :editable and :read- write are not synonyms,


> I think I understand what you have in mind here: in a browser, a text
field is
> :read- write if the user can type chars in the text field, and it's
> if for instance the user can select it, type on the delete key and
see it go 
> away?


> If that's what you have in mind, then yes, that's a very good catch,
> an important one. But in the specific case of text fields where user
> can affect the value of the element OR the contents/model of the
element, I
> think the names of both :read- write and :editable will be highly

I'm tempted to say that many things in CSS are :) But yes, I see your
point. Problem is, I do not have a better naming scheme at hand, except
maybe :contentEditable... But that's "just syntax" :), as long as we can
agree on the semantics.

... Allan
Received on Friday, 2 September 2005 15:34:00 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:27:20 UTC