W3C home > Mailing lists > Public > www-style@w3.org > September 1996

msie style error?

From: Carl Morris <msftrncs@htcnet.com>
Date: Thu, 19 Sep 1996 19:00:32 -0500
Message-Id: <199609200003.TAA20738@inet.htcnet.com>
To: "WWW Style List" <www-style@w3.org>
take a look at this html in MSIE 3.0:

	<P STYLE="margin-left: 1%; margin-right: 1%">

	<!-- first of all, this P tag should only effect the following table
when a non-table-enabled browser views this page, why is this P tag's
style affecting this at all?  Is MSIE chock full of style bugs further
than any MS programmer can ever hope to reverse?  Its gotta be close!
-->

    <TABLE>
		<TR>
			<TD>
                <A HREF="mailto:msftrncs@htcnet.com"><IMG
SRC="../../../icons/mail.gif" BORDER=0 WIDTH=32 HEIGHT=32 ALT=""></A>
			</TD>
			<TD>
				Are there problems with these pages?&nbsp; Contact the <A
HREF="mailto:msftrncs@htcnet.com">WebMaster</A> to report them!
			</TD>
		</TR>
	</TABLE>

I actually had this in one of my documents, but am about to remove it
... it was due to some testing when I found out that MSIE didn't
support the "first-line" element and so the <P> ahead of the table was
causing the table to display incorrectly...

Will someone stress to MS that a TABLE can not be contained in a P and
so the P should not effect the table...

-|- Carl Morris (N0YUV) -|- 1:285/302 -|- msftrncs@htcnet.com -|-
-|- Hooper Connections BBS -|- 1-(402)-654-2102 -|- 28.8kbps V.34 -|-
-|- http://199.120.83.179/~moreese/ -|-
Received on Thursday, 19 September 1996 20:00:52 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 27 April 2009 13:53:45 GMT