W3C home > Mailing lists > Public > www-rdf-logic@w3.org > January 2004

Re: "Transitive over" properties

From: Jeremy Carroll <jjc@hplb.hpl.hp.com>
Date: Sun, 04 Jan 2004 22:37:14 +0000
Message-ID: <3FF8959A.2040206@hplb.hpl.hp.com>
To: Jos De_Roo <jos.deroo@agfa.com>
Cc: "Mikhail Khlopotov <mik" <mik@chel.com.ru>, www-rdf-logic <www-rdf-logic@w3.org>

(still brainstorming on RDF logic, not formally responding to Mikail's comment)

> 
> If I understand it right, then for instance,
> given following facts
> 
> :worksFor :transitiveOver :consistsOf.
> :aCompany :consistsOf :rAndD.
> :rAndD :consistsOf :gSw.
> :gSw :consistsOf :gSwBe.
> :mk :worksFor :gSwBe.
> 


let's try and do this in OWL Full ...

:aCompany :consistsOf :rAndD.
:rAndD :consistsOf :gSw.
:gSw :consistsOf :gSwBe.
:mk :worksFor :gSwBe.


:consistsOf rdfs:subPropertyOf rdfs:subClassOf .
:worksFor rdfs:subPropertyOf rdf:type .
:worksFor rdfs:range :WorkArea .
:worksFor rdfs:domain :Worker .
:consistsOf rdfs:domain :WorkArea .
:consistsOf rdfs:range :WorkArea .

(hmmm :consistsOf is not a good name for my variant of this concept)

from which I can get as far as

:mk rdf:type :rAndD

but I need a 'property restriction' to say that an rdf:type relationship 
between a :Worker and a :WorkArea is a :worksFor relationship.

But I guess using the built-in transitive over relationship between 
rdf:type and rdfs:subClassOf is sort of cheating ...

I wonder whether some of the work of rules could be addressed differently 
by making OWL Full even bigger ... rules is probably a better idea.


Jeremy
Received on Sunday, 4 January 2004 17:42:39 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:52:48 GMT