W3C home > Mailing lists > Public > www-rdf-logic@w3.org > February 2001

Re: rdf:value backwards? [was: a few issues...]

From: pat hayes <phayes@ai.uwf.edu>
Date: Tue, 20 Feb 2001 11:05:55 -0600
Message-Id: <v04210100b6b853dde853@[]>
To: Dan Connolly <connolly@w3.org>
Cc: "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>, sandro@w3.org, www-rdf-logic@w3.org, www-rdf-comments@w3.org
>pat hayes wrote:
> > This is supposed to be saying that a string  has something as its
> > linguistic 'value', but the value comes first. In other words, it's
> > saying that the string is a NAME for the thing. So how about
> > rdf:nameIs, or (since this is being used with an equality sign which
> > conveys the 'is' already) rdf:nameOf or rdf:nameFor ?
>The closest W3C-Recommended precedent I can think of
>is rdfs:label; is that close enough?
>i.e. traditional-kr:Thing is to rdf:Resource
>as traditional-kr:Name is to rdfs:label.
>Perhaps it's best to exploit that precedent,
>but make a new name for this specialized use:
>	:lexRep a daml:UnambiguousProperty;
>		rdfs:subPropertyOf rdfs:label;
>		rdfs:domain xsd:anySimpleType;
>		rdfs:range xsd:string.

That seems OK. I kind of dislike having to switch from use to mention 
every time I see 'lexRep', but I guess I'm going to have to get used 
to this.


IHMC					(850)434 8903   home
40 South Alcaniz St.			(850)202 4416   office
Pensacola,  FL 32501			(850)202 4440   fax
Received on Tuesday, 20 February 2001 12:04:25 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:38:20 UTC