W3C home > Mailing lists > Public > www-rdf-interest@w3.org > July 2003

Re: FW: Re: (Round 2) Proposed Extensions to OWL

From: Benja Fallenstein <b.fallenstein@gmx.de>
Date: Sat, 05 Jul 2003 22:13:47 +0200
Message-ID: <3F07317B.7060805@gmx.de>
To: "Thomas B. Passin" <tpassin@comcast.net>
CC: "Roger L. Costello" <costello@mitre.org>, www-rdf-interest@w3.org

Thomas B. Passin wrote:
>>-----------------------------------------------------------------
>>Conceptual Model Property Hierarchies:
>>
>>    physicalProperty
>>          |
>>          |
>>  linearPhysicalProperty
>>          |
>>          |
>>        length
>>
>>Question: How would "area" fit into this property hierarchy?
> 
> physicalProperty
>    arealPhysicalProperty
>       area
> 
> Hmm, need to think some more about whether there is any significant
> difference between linearPhysicalProperty and length.  Maybe they are really
> synonyms and we can cut out one level.  Any one else want to contribute
> here?  My idea was that there are many kinds of linearPhysicalProperties,
> and "length" is only one of them.  For example, there could be "width" as
> well, and "height", and "thickness".  They are all linearPhysicalProperties,
> that is why I had the third layer.  Much as I would like to cut out the
> third level, I still think that it is correct modeling to keep it.

I would suggest

physicalProperty
    lengthProperty
       foo:length
       bar:width
       baz:height
       a:size

    areaProperty
       wombat:area
       b:size

I.e., call it a "length property" (as meters and feet are "standards of 
length"). It does make sense that there would be a single vocabulary 
defining "lengthProperty," but many different vocabularies which define 
special lengthProperties. A pond of water doesn't have a length, but it 
may have a pond:depth-- which would be a lengthProperty.

However, I am wondering; what is preferable about the above approach vs.

Property
    PhysicalProperty
       LengthProperty
       AreaProperty

and then have

    wombat:area   rdf:type   AreaProperty

?

Or is this definition too close to RDF already and you want to specify 
something on a more abstract level?

- Benja
Received on Saturday, 5 July 2003 16:15:06 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:52:00 GMT