W3C home > Mailing lists > Public > www-rdf-interest@w3.org > November 2001

Re: naming properties and classes in RDF

From: Geoff Chappell <geoff@sover.net>
Date: Fri, 16 Nov 2001 11:42:09 -0500
Message-ID: <00dd01c16ebd$a38e97b0$0400a8c0@GSC866>
To: "Libby Miller" <Libby.Miller@bristol.ac.uk>, "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>
Cc: <Libby.Miller@bristol.ac.uk>, <www-rdf-interest@w3.org>, <neil.jacobs@bristol.ac.uk>, <g.conole@bristol.ac.uk>

----- Original Message -----
From: "Libby Miller" <Libby.Miller@bristol.ac.uk>
To: "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>
Cc: <Libby.Miller@bristol.ac.uk>; <www-rdf-interest@w3.org>;
<neil.jacobs@bristol.ac.uk>; <g.conole@bristol.ac.uk>
Sent: Friday, November 16, 2001 11:32 AM
Subject: Re: naming properties and classes in RDF


> >
> > I'm not sure what you consider to be redundant here.  The only things
that
> > are typed twice are <rdf:type>, <_:1>, and <_:2>.
>
> Hi Peter
>
[...]

> Does this ring any bells with anyone?

I know what you mean - sometimes feels a little awkward and potentially
error-prone to have a property name and a class name differing only in the
capitalization of the first letter (and the range of the property being the
class). Maybe some sort of other naming convention would help - a la:

  PResearch_interest
  CResearch_interest

I usually just end up adorning the property name with some additional info -
i.e. processingScript points to an object of type Script.

>
> thanks again
>
> libby
>
>

Geoff
Received on Friday, 16 November 2001 11:46:24 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:51:52 GMT