W3C home > Mailing lists > Public > www-rdf-comments@w3.org > October to December 2002

Re: RDF Core WG draft of RDF/XML Syntax Specification (Revised) for review

From: Daniel Krech <eikeon@eikeon.com>
Date: 31 Oct 2002 12:10:28 -0500
To: Dave Beckett <dave.beckett@bristol.ac.uk>
Cc: "www-rdf-comments@w3.org" <www-rdf-comments@w3.org>
Message-Id: <1036084229.21247.51.camel@panther>

On Mon, 2002-10-28 at 17:07, Dave Beckett wrote:

<snip/>

> > >>  then why not define the productions with anyURI in them as follows:
> > >>
> > >>      nodeElementURIs = rdf:Description | classURI | rdf:nil | anyURI
> > >>                        except from the RDF namespace
> > >>
> > >>      propertyElementURIs = rdf:li | propertyURI | anyURI except from
> > >>                            the RDF namespace
> > >>
> > >>      propertyAttributeURIs = anyURI except from the RDF namespace
> > >>
> > >>    where:
> > >>
> > >>      classURIs = SEQ | BAG | ALT | STATEMENT | PROPERTY | LIST
> > >>
> > >>      propertyURIs = SUBJECT | PREDICATE | OBJECT | TYPE | VALUE | FIRST
> > >>                     | REST | _n
> > >
> > >
> > >I do like the classURIs & propertyURIs split and will consider this.
> > >Particularly I like it if it matches the namespace split too in 5.1.
> > 
> > Whoa!! Am I following this right? Do we now have a syntactic 
> > distinction between property URIs and Class URIs? If so, I protest 
> > strongly. There should be no such syntactic distinction in RDF.  This 
> > will break RDFS.
> 
> 
> No, you are not reading it right and it was just a suggestion.
> 
> Firstly, I wasn't going to use it exactly as Daniel suggested, but
> was instead thinking of using this to break down the longer list I
> had:
> 
>   7.2.2 syntaxTerms           := rdf:RDF | rdf:ID | rdf:about | rdf:bagID | rdf:parseType | rdf:resource | rdf:nodeID | rdf:datatype
>   7.2.3 nodeElementURIs       := anyURI - ( syntaxTerms | rdf:li )
>   7.2.4 propertyElementURIs   := anyURI - ( syntaxTerms | rdf:Description | rdf:nil)
>   7.2.5 propertyAttributeURIs := anyURI - ( syntaxTerms | rdf:Description | rdf:li | rdf:nil)
> 
> into something that matched more accurately the description we've had
> for months, of the terms in the RDF namespace section 5.1:
> 
>   http://ilrt.org/discovery/2001/07/rdf-syntax-grammar/#section-Namespace
> 
> which consists of syntax terms, classes, properties and resources.
> 
> 
> > When was this decision taken??
> 
> The syntax document has had the namespace terms split in the draft
> for months and as I recall was done after we discussed how to present the
> RDF namespace it was felt that 5.1
>   http://ilrt.org/discovery/2001/07/rdf-syntax-grammar/#section-Namespace
> was easier to explain betwen syntax terms and other things by
> separating them out; like rdf:datatype is a syntax thing (will not
> appear in the schema) and rdf:Seq will.
> 
> 
> --
> 
> The above terms Daniel was describing were never used alone in his
> form, merely to explain where rdf-namespaced terms were allowed.
> 
> For example, classURIs was never be used on its own, Daniel proposed:
> 
>      nodeElementURIs = rdf:Description | classURI | rdf:nil | anyURI
>                        except from the RDF namespace
> 
> and although I wasn't quite agreeing with that, you could *not* tell
> anything about any particular term (which is an XML element) apart
> from whether it was legal to use at that point in the XML syntax.
> 
> --
> 
> On further consideration, I'm not going to what Daniel asks, but will
> modify syntaxTerms, since it is misnamed - it doesn't contain all the
> terms that are syntax only (it leaves out rdf:Description and rdf:li) -
> and add a new grammar term.

Not a big issue... but thought it was worth one more time around.

Not sure I followed what the objection was (if any?) to being more
explicit and precise about the productions 7.2.2 - 7.2.5. [And
syntaxTerms still leaves out rdf:Description and rdf:li as things
currently stand]

My original motivation remains. To me it mattered not if the notion of
classURI and propertyURI where introduced... they could be expanded in
place below and achieve what I was after. 

The key difference I was after is to explicitly list what is allowed
from the RDF namespace then add to it any other URI that is not from the
RDF namespace. Seems more straight forward and less likely for error to
creep in when defining, interpreting and implementing them. For
instance, as 7.2.5 now stands it allows the class names from the RDF
namespace -- do we really want to allow class names here?	

The proposed productions again... and slightly fixed up from before:

    nodeElementURIs = rdf:Description | classURI | 
                      anyURI except from the RDF namespace

    propertyElementURIs = rdf:li | propertyURI | 
                          anyURI except from the RDF namespace

    propertyAttributeURIs = propertyURI | anyURI except from the RDF namespace
Received on Thursday, 31 October 2002 12:10:36 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 21 September 2012 14:16:31 GMT