W3C home > Mailing lists > Public > www-rdf-comments@w3.org > January to March 2001

Re: rdf:value backwards? [was: a few issues...]

From: Dan Connolly <connolly@w3.org>
Date: Mon, 19 Feb 2001 13:42:05 -0600
Message-ID: <3A91770D.2DF35A0C@w3.org>
To: pat hayes <phayes@ai.uwf.edu>
CC: "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>, sandro@w3.org, www-rdf-logic@w3.org, www-rdf-comments@w3.org
pat hayes wrote:
> This is supposed to be saying that a string  has something as its
> linguistic 'value', but the value comes first. In other words, it's
> saying that the string is a NAME for the thing. So how about
> rdf:nameIs, or (since this is being used with an equality sign which
> conveys the 'is' already) rdf:nameOf or rdf:nameFor ?

The closest W3C-Recommended precedent I can think of
is rdfs:label; is that close enough?

i.e. traditional-kr:Thing is to rdf:Resource
as traditional-kr:Name is to rdfs:label.

Perhaps it's best to exploit that precedent,
but make a new name for this specialized use:

	:lexRep a daml:UnambiguousProperty;
		rdfs:subPropertyOf rdfs:label;
		rdfs:domain xsd:anySimpleType;
		rdfs:range xsd:string.

html:title and dc:title are in the neighborhood there
somewhere too.

"Provides a human-readable version of a resource name."
-- http://www.w3.org/2000/01/rdf-schema#label

"This is used to provide a human-readable version of a resource name. "
-- http://www.w3.org/TR/2000/CR-rdf-schema-20000327/#s5.2

see also

traditional-kr, e.g. algernon

True Names and Public Names

Dan Connolly, W3C http://www.w3.org/People/Connolly/
Received on Monday, 19 February 2001 14:47:12 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:15:13 UTC