W3C home > Mailing lists > Public > www-ql@w3.org > July to September 2004

RE: XQuery Usecase "PART" incorrect?

From: Michael Kay <mhk@mhk.me.uk>
Date: Fri, 24 Sep 2004 12:50:22 +0100
To: "'Probst, Martin'" <martin.probst@sap.com>, <www-ql@w3.org>
Message-ID: <E1CAobK-0001u2-IA@frink.w3.org>

> 
> Well, in that case you would further complicate the lexing of 
> XQueries. 

Yes, it's messy. It's especially silly as the SequenceType empty() has no
useful purpose. But making users prefix this one function would be worse. My
vote would be change the SequenceType empty() to (say) void(). But frankly,
I want to see this spec finished, this kind of tinkering can go on for ever.

Michael Kay
Received on Friday, 24 September 2004 11:50:58 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:17:16 UTC