[Prev][Next][Index][Thread]

Re: Cache Proxy Server



The version of the HTTPD source that you have does not support the newest 
libwww source.  You can get the older libwww (2.17) source instead.

-Calvin

To:     www-proxy @ w3.org@SMTP
cc:      
From:   Saadiah Yahya <saadiah @ sel.itm.my> @ SMTP
Date:   11/10/95 08:41:24 PM
Subject:        Cache Proxy Server



To whom it may concern,

I am a research student at the UPM Malaysia. For the past few days I have
been busy fixing the problems I encountered in setting up a cache proxy
server. For your information:-

1. My platform is a PC with a Linux OS.

2. I have copied httpd_src.tar.Z and libwww_src.tar.Z files to my server.
   I have uncompressed and untarred both files.


3. The build up process was successfully done for the library( As it was
   stated with the 0 status)  as well as for the linemode. But as when I
   tried to build for the daemon by the  ./BUILD daemon, I have got
   the following respond:

   ------------------------------------------------------
   building CERN httpd, htadm, htimage, cgiparse, cgiutils
   object files and binaries will go to the directory Daemon/Linux
   Make[1] Entering directory 'app/WWW/Daemon/Linux'
   .
   .
   .
   HTDaemonDiR.C:152: HTFWriter.h : No such file or directory
   Make[1]. *** [HTDaemonDir.o] Error1
   Make[1]: leaving directory 'app/WW/Daemon/Linux'
   Make: *** [../../Daemon/Linux/httpd] Error2
   WWW build for linux done. Status=2
  --------------------------------------------------------

 4.  you see, I have encountered 2 errors. How can these happening?.

 5.  Do you strictly follow the version i.e. Linux version 1.2.10?

 6.  I have configured the caching.conf file by fixing the ServerRoot and
     the cache appropriate directory and leave the rest unchange at the
     moment, configured the client browser(Netscape) to make request
     via my proxy server(By filling the Option, Preference form), But I
     seem to have this message

      ---------------------------------
      A network error occurred while Netscape
      was receiving data.
      (Network Error. Socket is not connected)
      Try connecting again
     ----------------------------------
    My questions are:

    a) Was this the subsequent effect of my failing in the daemon
       Building Process, mentioned above at (3)?.

    b) Could it be because I have not done the correct thing in
       configuring the caching file at the config directory? Should I
       configured all file in the config directory(which I think not)?

    c) Do we need to install the appropriate browser at the cache proxy
       server to accomadate the http passing?.(Which I think not as well)

Please help me by urgently reply this mail.
I am desperate. Thank you very much and regards.

Saadiah.

1. saadiah@sel.itm.my      Or
2. saadiah@pjj.ccrisc.upm.my.



 


Follow-Ups: