[Prev][Next][Index][Thread]

Re: configure to handle POST




	You got caught out as I did: the configuration directives
	have to be in a certain order.  Here's what Henrik Frystyk
	had to say:

>
>Harold,
>
>The problem is that you must put the Exec rules before the pass rules:
>
>> 
>> #
>> # Scripts
>> #
>> Exec            /htbin/*        /usr/local/WWW/Bin/* 
>> #POST-Script	/usr/local/WWW/Bin/do-nothing
>
>> #
>> #	Pass the URLs that this proxy is willing to forward.
>> #
>> Pass	http:*
>> Pass	ftp:*
>> Pass	gopher:*
>> Pass	wais:*
>> Pass    /*      /usr/local/WWW/*
>> #
>
>Then it will work!
>
>
>-- cheers --
>
>Henrik Frystyk
>frystyk@W3.org
>+ 41 22 767 8265
>World-Wide Web Project,
>CERN, CH-1211 Geneva 23,
>Switzerland



>Date: Thu, 08 Jun 1995 02:36:15 +0500
>From: David Dumaresq <david@kwantlen.bc.ca>
>Subject: configure to handle POST
>Sender: www-proxy@www10.w3.org
>To: Multiple recipients of list <www-proxy@www10.w3.org>
>
>Greetings:
>
>I'm new at setting up forms with our CERN httpd proxy server and have, 
>not suprisingly, ran into a snag. 
>
>After linking a form that calls a bourne shell script in the cgi-bin 
>directory the server responds:
>
>	HTTP/1.0 500 This server is not configured to handle POST
>
>I have added 'Enable POST' to the httpd.conf but this does not make a 
>difference. The docs say that GET and POST are enabled by default in any 
>case.
>
>I appreciate any help you can offer.
>
>Thanks,
>David.


Harold March                            CMC DECnet: AV410A::MARCH
Canadian Marconi Company                  Internet: march@mtl.marconi.ca
MIS/IT                                  CompuServe: 76424,3451
TEL: 514-748-3000 ext 4467                     FAX: 514-748-3136