W3C home > Mailing lists > Public > www-p3p-policy@w3.org > February 2002

Validator can't find PRF with HTTPS

From: Kim Hahn <KHahn@digitalimpact.com>
Date: Wed, 27 Feb 2002 15:46:11 -0800
Message-ID: <D09EEBE0D49B4748B8276F91C3C3FA65051F6C58@DIEXGSM1.digitalimpact.com>
To: "'www-p3p-policy@w3.org'" <www-p3p-policy@w3.org>
Hello, 

This issue was addressed in "Re: IE6 and finding the policy summary with
https" but no resolution was posted.
I'm having the same problem.

I have a valid p3p policy and /w3c/p3p.xml installed on a secure server.
secure URL https://secureServer/w3c/p3p.xml 
non-secure  http://server/w3c/p3p.xml 

Using: 
P3P Validator http://www.w3.org/P3P/validator.html (latest)
IE 6.0.2600.0000 (latest version)

The Validator is unable to find the PRF for the secure URL. During Step 1-1:
Access Check, I receive: 
"Warning: 501 Protocol scheme 'https' is not supported
[uri=https://secureServer/w3c/p3p.xml/]" But it can find the PRF and
associated policy for the the non-secure URL.

On the browser, I can view the PRF file directly using both URL's. Using the
View->Privacy Report... feature, you can display the p3p policies for both
URL's.

Because both URLs are accessible via the browser, I'm wondering if there is
a bug in the Validator that it cannot find secure PRF files. Does anyone
have a live secure URL I that I could try?

Kim
Received on Wednesday, 27 February 2002 18:46:47 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 17 January 2012 12:13:10 GMT