W3C home > Mailing lists > Public > www-p3p-policy@w3.org > August 2002

Re: Problem to see the privacy report summary

From: Lorrie Cranor <lorrie@research.att.com>
Date: Fri, 16 Aug 2002 14:17:56 -0400
Message-ID: <010701c24551$3ebe4680$9816cf87@barbaloot>
To: <rcbm@terra.com.br>, <www-p3p-policy@w3.org>

The URL you put in the header should be for a policy
reference file, not for a policy. The policy reference
file then gives the location of the policy.

Lorrie Cranor

--
Lorrie Faith Cranor - http://lorrie.cranor.org/
P3P Specification Working Group Chair - http://www.w3.org/p3p/
New book: Web Privacy with P3P - http://p3pbook.com/


----- Original Message ----- 
From: "Ricardo Bueno Moreira" <rcbm@terra.com.br>
To: <www-p3p-policy@w3.org>
Sent: Friday, August 16, 2002 2:22 PM
Subject: Problem to see the privacy report summary


> 
> Hi there,
> 
>   My server is sending the P3P header below along with a Set-Cookie:
> 
> P3P: policyref="http://www.mysite.com/w3c/mypolicy1.xml", CP="NOI DSP
> COR NID CURa ADMa DEVa PSAa PSDa OUR IND COM NAV INT"
> 
> 
>   The browser is accepting the cookie according to the privacy settings,
> that's ok.
> 
>   BUT, the problem is: if the user wants to see the summary from the
> privacy report (browser IE 6.0.26), the browser do not consider
> the location sent in P3P header, it tries to get the policy from the
> default location:
> 
>   "http://www.mysite.com/w3c/p3p.xml"
> 
> instead of the location my server sent:
> 
>   policyref="http://www.mysite.com/w3c/mypolicy1.xml"
> 
>   According with P3P specification it's all correct, but it's not
> workink. Any help with this?
> 
>   Well, that's it. I hope It's all clear.
> 
>   Best regards,
> 
> --
>   []'s Ricardo
> 
> 
Received on Friday, 16 August 2002 14:27:00 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 17 January 2012 12:13:10 GMT