W3C home > Mailing lists > Public > www-math@w3.org > June 2003

MathML and the XSL stylesheets in mozilla

From: Richard Kaye <R.W.Kaye@bham.ac.uk>
Date: Thu, 12 Jun 2003 14:42:52 +0100
To: davidc@nag.co.uk, www-math@w3.org
Message-Id: <200306121442.52372.R.W.Kaye@bham.ac.uk>

Dear David and WWW-math

I'm having some very puzzling problems with using your 
XSL stylesheets together with MathML and Mozilla.  I 
wondered if you know of any issues to do with this combination.

I downloaded the xsl.zip file from 
http://www.w3.org/Math/XSL/Overview-tech.html
and installed it at http://mat140.bham.ac.uk/~richard/w3c/
I then point and click pmailml.xml (for example).

If I am using Netscape 7 all is fine, I see some nice (?) maths.
It works fine with IE 5.5 or 6.0 and mathplayer 1.0 too.
With Mozilla 1.2.1 or 1.3.1, I just get a dark grey blank screen
and the word "Done" at the bottom. 

Mozilla **is** happy at reading the same files (I presume they are!)
served from the w3c at http://www.w3.org/Math/XSL/pmathml.xml
and is also happy when I edit out the
<?xml-stylesheet type="text/xsl" href="pmathml.xsl"?>
line (but then of course IE doesn't view the file properly).

This is very puzzling.  If it has something to do with the
way my web server is set up, I can change it, but I'm not a guru
in such things and don't see why it should be necessary when
Netscape and IE are happy.

I have two client machines for testing as follows:

1. Windows 98SE. Mozilla 1.2.1, IE6+Mathplayer

2. Windows ME. Mozilla 1.3.1, IE5.5+mathplayer, Netscape 7

My server is running SuSE 8.1, and the httpd is Apache 1.3.26.

Many thanks in advance for your help.

Richard Kaye
Received on Thursday, 12 June 2003 10:01:24 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Saturday, 20 February 2010 06:12:55 GMT