W3C home > Mailing lists > Public > www-lib@w3.org > January to March 2001

building on Reliant

From: Judd Rogers <Judd_Rogers@bmc.com>
Date: Fri, 16 Mar 2001 15:42:09 -0600
Message-ID: <3AB288B1.8C7E8C94@bmc.com>
To: www-lib@w3.org
CC: "Deshakulakarni, Chandra" <Chandra_Deshakulakarni@bmc.com>

An update: the problem was the link was missing library dl. Once I
manually edited src/Makefile to include it all was fine.

How do I fix the Makefile.conf or the configure script to add dl on


I am building on a reliant box and I get a link error:
/usr/bin/cc -c  -I./os/unix -I./include   -DSVR4 -D_XPG_IV -DHAS_DLFCN
XPAT -I./lib/expat-lite `./apaci` buildmark.c
-I./lib/expat-lite `./ap
aci`   -Wl,-Blargedynsym \
      -o httpd buildmark.o modules.o modules/standard/libstandard.a
.a ./os/unix/libos.a ap/libap.a regex/libregex.a
lib/expat-lite/libexpat.a  -lso
cket -lnsl -lc
Undefined                       first referenced
 symbol                             in file
dlsym                               ./os/unix/libos.a(os.o)
ld: httpd: fatal error: Symbol referencing errors. No output written to
make[2]: *** [target_static] Error 1

I ran configure like this:
CC=/usr/bin/cc \
./configure \
--prefix=/opt/BMC_Software/apache.1.3.17 \
--with-layout=Apache \

uname -a produces:
ReliantUNIX-N bldsnix1 5.44 C2001 RM400 2/1024 R10000


Judd Rogers
BMC Software
Received on Friday, 16 March 2001 16:44:13 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:33:53 UTC