W3C home > Mailing lists > Public > www-lib@w3.org > July to September 2000

chunkbody dumps core on non-existent local files (HTLoadAnchorToChunk problem ?)

From: g.p.ciceri <gp.ciceri@acm.org>
Date: Mon, 11 Sep 2000 23:43:44 +0200
Message-ID: <39BD5210.6D275F0E@acm.org>
To: www-lib@w3.org
hello all,
I'm testing the latest libwww-5.3.1
and I'm having problems with the samples:
in particular, when testing chunk, chunkbody on a non-existent local
file I take a segfault, 
like in the following

[zanzi@agnese .libs]$ ./chunkbody dsadas
file:/home2/zanzi2/w3c-libwww-5.3.1/Library/Examples/.libs/
file:/home2/zanzi2/w3c-libwww-5.3.1/Library/Examples/.libs/dsadas
Segmentation fault (core dumped) 

If I ask a non-existing URL it works, like in the following

[zanzi@agnese Examples]$ ./chunkbody http://foo.bar.baz
file:/home2/zanzi2/w3c-libwww-5.3.1/Library/Examples/
http://foo.bar.baz/       
no text

I'm using a RH6.1 linux, BTW.
Anyone able to reproduce this behaviour, please ???
Any help will be useful.

Regards
/gp 

-- 
Discussion: How do you feel about Open Source firms making 
millions through public offerings?

"I wish these companies were making the same millions without
distributing any non-free, user-subjugating software." --
                                             Richard Stallman 

"We're not here to let the monkey dances" --
											 g.p.

  Gian Paolo Ciceri        Via B.Diotti 45 - 20153 Milano MI ITALY
      CTO @ TiALabs        mobile :   ++39 347 4106213        
                           eMail  :   gp.ciceri@acm.org  
                           webSite:   http://www.tialabs.com

Received on Monday, 11 September 2000 17:46:40 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:38 GMT