W3C home > Mailing lists > Public > www-lib@w3.org > July to September 2000

Planning to upgrade expat

From: <jose.kahan@w3.org>
Date: Fri, 25 Aug 2000 15:00:15 +0200 (MET DST)
Message-Id: <200008251300.PAA11655@tuvalu.inrialpes.fr>
To: www-lib@w3.org
Hello,

Today we're using the latest stable release of Expat inside libwww
(libwww/modules/expat)

We're now using a more recent expat within Amaya, which is available
at James Clark's site as the "development version". We chose this version
because it has an extended API and provides some useful functions for working
with XML.  This version is the one being used today by the Perl XML modules.

At the same time, the Perl developers have made available a patch file
for expat which enhances and fixes some problems with expat.

I'd like to upgrade libwww's expat version to the "development version" and
then, later on, apply the above patches to it.

I'd tag the current expat version of libwww so that we could backtrack in
case of problems.

Does anyone have any objections to my doing so? 

I can always commit those changes to the Amaya tagged version of libwww.

Thanks,

-Jose
Received on Friday, 25 August 2000 09:00:19 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:37 GMT