W3C home > Mailing lists > Public > www-lib@w3.org > January to March 1999

HELP -- NETREAD hangs when loading URL that sets cookie.

From: Abe Lederman <lederman@roadrunner.com>
Date: Sun, 28 Feb 1999 20:34:59 -0500 (EST)
Message-Id: <3.0.1.32.19990228183758.0097c160@roadrunner.com>
To: www-lib@w3.org

I posted this email about a week ago and have gotten no response. Sorry
for reposting it.

I have a problem that is driving me nuts.

I'm running version 5.2.1 of libwww (I have also tried this on a
snapshot of CVS that I downloaded
yesterday) on a Solaris 2.5.1 machine.

When I do a POST (problem also occurs when doing a GET) against a HTTP
1.0 server, and a Set-Cookie header is returned, libwww hangs in the
NETREAD call in HTReader.c

The problem doesn't occur if the Set-Cookie header isn't returned, and
the problem doesn't occur when talking to a newer 1.1 server.

When running non-preemptively, then libwww hangs in a select and it
looks like the server is returning the URL correctly.

I have tried setting connection mode to HTTP_FORCE_10 and it hasn't made
a difference.

Any help would be greatly appreciated.
Received on Monday, 1 March 1999 02:34:43 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:29 GMT