W3C home > Mailing lists > Public > www-lib@w3.org > October to December 1998

RE: ComLine tool Problem

From: olga <olga@goliath.eai.com>
Date: Thu, 29 Oct 1998 09:39:39 -0600 (CST)
Message-ID: <XFMail.981029093939.olga@eai.com>
To: Brian Weller <weller@source.computize.com>
Cc: www-lib@w3.org
Hello,

It is not an answer how to solve it. I had same problem. I tried do several
POSTs in a row (or GET after POST) and hanged in the first one. May be different
profile should be used? I used  HTProfile_newPreemptiveClient. I was not able
to find out how to make it work so I implemented POST by hand (Get works
through w3c and POST creates socket, opens connection and so on... It
is ugly but at least works.) I am writing because I am also interested in
solving the problem you describe. I gave up earlier because it was
taking too much time which I did not have...

Thanks,

Olga Antropova.


On 29-Oct-98 Brian Weller wrote:
> Hi,
> 
> I'm having a problem using the ComLine tool in the library.  GET seems to  
> work fine, but when I use POST the process just hangs in the same place ever 
> time.  I have also tried to use the POST example from Library/Examples but I 
> get same result. What am I doing wrong?
> 
> I've included the extra trace output of the w3c transaction below.
> 
> FYI: I grabbed the CVS tree of the library yesterday.  I'm running on  
> OpenStep 4.2/Intel. I also tried 5.1m and 5.1j but I had the same problem.
> 
> ./w3c -vsop -post http://hoohoo.ncsa.uiuc.edu/cgi-bin/post-query -form  
> "aKey=myValue" "aKey2=myOtherValue"
> 
> Host........ Setting event timeout to 20000 ms
> HTAccess.... Accessing document
> http://hoohoo.ncsa.uiuc.edu/cgi-bin/post-query
> Net Before.. calling 0xe0d4 (request 0x270274, context 0x0)
> Net Before.. calling 0xe060 (request 0x270274, context 0x0)
> Net Before.. calling 0xe814 (request 0x270274, context 0x0)
> URL Tree.... did NOT find `w3c-AA'
> Credentials. verified
> Net Before.. calling 0x30fd8 (request 0x270274, context 0x0)
> URL Tree.... did NOT find `w3c-pep'
> Net Before.. calling 0xdfac (request 0x270274, context 0x0)
> Net Object.. 0x2757ac created with hash 0
> Net Object.. starting request 0x270274 (retry=1) with net object 0x2757ac
> HTTP........ Looking for `http://hoohoo.ncsa.uiuc.edu/cgi-bin/post-query'
> HTDoConnect. Looking up `hoohoo.ncsa.uiuc.edu'
> Event....... Created event 0x276180 with context 0x2762cc, priority 20, and  
> timeout 20000
> Event....... Created event 0x276374 with context 0x2762cc, priority 20, and  
> timeout 20000
> Event....... Created event 0x27638c with context 0x2762cc, priority 20, and  
> timeout 20000
> Host info... added `hoohoo.ncsa.uiuc.edu' with host 0x2762cc to list 0x2755a0
> Host info... Add Net 0x2757ac (request 0x270274) to pipe, 1 requests made, 1 
> requests in pipe, 0 pending
> HTHost...... No ActivateRequest callback handler registered
> HTHost 0x2762cc going to state TCP_CHANNEL.
> HTHost 0x2762cc going to state TCP_DNS.
> Looking up hoohoo.ncsa.uiuc.edu
> DNS Add..... `hoohoo.ncsa.uiuc.edu' with 1 home(s) to 0x2764c0
> ParseInet... as port 80 on 141.142.103.54 with 1 homes
> HTHost 0x2762cc going to state TCP_NEED_SOCKET.
> Socket...... Created 3
> Net Manager. Increasing active sockets to 1, 0 persistent sockets
> Socket...... Turned off Nagle's algorithm
> Socket...... Non-blocking socket
> Channel..... Hash value is 3
> Channel..... Added 0x276680 to list 0x276674
> Reader...... Created reader stream 0x2766bc
> Socket...... TCP send buffer size is 4096 for socket 3
> Contacting hoohoo.ncsa.uiuc.edu
> HTHost 0x2762cc going to state TCP_NEED_CONNECT.
> HTHost 0x2762cc going to state TCP_CONNECTED.
> HTHost 0x2762cc connected.
> StreamStack. Constructing stream stack for text/x-http to */*
> Tee......... Created stream 0x27f840 with resolver 0x36f08
> HTTP........ Dumping request to `w3chttp.out'
> Host Event.. FLUSH passed to `http://hoohoo.ncsa.uiuc.edu/cgi-bin/post-query'
> HTTP........ Generating HTTP/1.x Request Headers
> HTTP........ Generating General Headers
> MIME........ Generating Entity Headers
> Buffer...... Flushing 0x27e6d8
> Write Socket 314 bytes written to 3
> Writing 1Kbytes
> Uploading... Holding 0x2755e0 for 2000 ms using time 0x28191c

----------------------------------
E-Mail: olga <olga@eai.com>
Date: 29-Oct-98
Time: 09:30:10

This message was sent by XFMail
----------------------------------
Received on Thursday, 29 October 1998 10:36:46 EST

This archive was generated by hypermail pre-2.1.9 : Wednesday, 3 September 2003 17:59:20 EDT