W3C home > Mailing lists > Public > www-lib@w3.org > July to September 1998

Re: webbot: hangs in HTEventList

From: John Punin <puninj@cs.rpi.edu>
Date: Tue, 4 Aug 1998 16:18:23 -0400 (EDT)
Message-Id: <199808042018.QAA24010@dishwasher.cs.rpi.edu>
To: berrym@isc.upenn.edu (Mike Berry)
Cc: puninj@cs.rpi.edu (John Punin), www-lib@w3.org
Hi Mike
I had the same problem. You should get the patch for HTHost.c from the :
http://dev.w3.org/cgi-bin/cvsweb/libwww/Library/src/HTHost.c

Recompile the web library and webbot will work fine. 
Best wishes
John Punin

> 
> The webbot example program hangs after a brief period of normal
> operation; typically after 50-100 "outstanding requests" have piled
> up.  This happens on sun and digital; compiled with gcc on the sun and
> cc on the digital:
> 
> 	- SunOS 5.5.1 Generic_103640-20 sun4u sparc SUNW,Ultra-2      
> 	- OSF1 V4.0 878 alpha
> 
> This behaviour occurs with any starting URI however the number of
> "outstanding requests" which accumulate differs depending on the site.
> 
> I *must* be doing something wrong.  Can someone kindly point me in the
> right direction?
> 
> Some clues:
> -----------
> 
> Robot....... done with http://www.seas.upenn.edu/history.html
>              54 outstanding requests
> >>>...program hangs...<<<
> ^C
> Program received signal SIGINT, Interrupt.
> 0xef63790c in _poll ()
> (gdb) where
> #0  0xef63790c in _poll ()
> #1  0xef653d48 in select ()
> #2  0x37ba8 in HTEventList_loop (theRequest=0x83e58) at HTEvtLst.c:817
> #3  0x201c0 in main (argc=8, argv=0xeffff8c4) at HTRobot.c:1784
> (gdb)
>        
> 
> Mike
> ---
> Mike Berry, ISC Network Services
> Information Systems and Computing, University of Pennsylvania
> Voice:(215)/898-1264   Fax:(215)/898-9348     E-mail:<berrym@isc.upenn.edu>
> 
> 
> 
Received on Tuesday, 4 August 1998 16:18:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:28 GMT