W3C home > Mailing lists > Public > www-lib@w3.org > July to September 1998

Re: Possible libwww-5.1m bug in HTHost_free or HTChannel_new

From: Henrik Frystyk Nielsen <frystyk@w3.org>
Date: Mon, 06 Jul 1998 15:40:38 -0400
Message-Id: <3.0.5.32.19980706154038.00b1e100@localhost>
To: Aaron Colwell <colwaar@charlie.cns.iit.edu>, www-lib@w3.org
At 11:19 6/25/98 -0500, Aaron Colwell wrote:

>I figured that this was a good place to get a solution to my
>problem. It seems to do what I need it to do. Once I made this change and
>recompiled the whole library everything started working beautifully.
>Seeing as I dont really have a completely informed view of how everything
>works together I dont really know how this impacts all aspects of the code
>in the library, but it fixed the problem that I was having. If this is
>wrong please look into the problem and send me the 'right' solution. I'm
>sorry about the long winded explaination, but I think it was necessary to
>describe my thought process and reasons for doing what I did. Thanks for
>your help and I'd appreciate any comments.

I had a closer look and this is indeed the problem. I have no idea how I
could delete that line - well done!

This bug also had a quite catastrophic impact on HTTP/1.0 accesses - it
made the robot hang, for example. This is now fixed - the change is
commit'ed to CVS and you can see the diff at

	http://dev.w3.org/cgi-bin/cvsweb/libwww/Library/src/HTHost.c

Henrik
--
Henrik Frystyk Nielsen,
World Wide Web Consortium
http://www.w3.org/People/Frystyk
Received on Monday, 6 July 1998 15:40:16 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:28 GMT