W3C home > Mailing lists > Public > www-lib@w3.org > April to June 1998

Re: Libwww Release 5.1m problem

From: Henrik Frystyk Nielsen <frystyk@w3.org>
Date: Mon, 01 Jun 1998 19:54:40 -0400
Message-Id: <3.0.5.32.19980601195440.00c93b30@localhost>
To: John Punin <puninj@cs.rpi.edu>
Cc: www-lib@w3.org
At 16:26 6/1/98 -0400, John Punin wrote:

>I have a quick question. I'm trying to install the new version of the library. 
>I run the configure with these parameters
>
>./configure --with-regex=/mydir/rx-1.5/lib/librx.a --prefix=/mydir/w3c-libwww-5.1m --disable-shared

Hmm - it's because the extra library doesn't use -L and -l but
is included as an object. Please try and run configure
again like this

LDFLAGS='-static' ./configure --with-regex=/mydir/rx-1.5/lib/librx.a --prefix=/mydir/w3c-libwww-5.1m --disable-shared

and see if that helps

Henrik

>The 'wwwconf.h' is generated without problems. I run 'make' and when the Library is linked, I
>got this problem:
>
>../../libtool --mode=link gcc -g -O2  -o libwww.la -rpath /mydir/w3c-libwww-5.1m/lib -version-info 1:0:1 HTParse.lo HTAccess.lo HTProxy.lo HTMethod.lo HTProt.lo HTCache.lo HTReqMan.lo HTDNS.lo HTArray.lo HTFile.lo HTBTree.lo HTMulti.lo HTFTP.lo HTTCP.lo SGML.lo HTML.lo HTMLPDTD.lo HTDir.lo HTFTPDir.lo HTEPtoCl.lo HTStyle.lo HTPlain.lo HTWriter.lo HTFWrite.lo HTMLGen.lo HTTee.lo HTXParse.lo HTChunk.lo HTAtom.lo HTAnchor.lo HTList.lo HTString.lo HTAlert.lo HTFormat.lo HTHist.lo HTMemory.lo HTInit.lo HTBInit.lo HTRules.lo HTMIME.lo HTMIMERq.lo HTBound.lo HTConLen.lo HTHeader.lo HTBind.lo HTGopher.lo HTTelnet.lo HTNetTxt.lo HTNews.lo HTWSRC.lo HTSocket.lo HTAAUtil.lo HTAABrow.lo HTAssoc.lo HTUU.lo HTTeXGen.lo HTEscape.lo HTDescpt.lo HTGuess.lo HTWWWStr.lo HTIcons.lo HTError.lo HTLog.lo HTHome.lo HTDialog.lo HTNDir.lo HTTP.lo HTTPServ.lo HTNewsRq.lo HTTPGen.lo HTTPReq.lo HTTPRes.lo HTNet.lo HTEvtLst.lo HTNewsLs.lo HTUser.lo HTMIMPrs.lo HTEvent.lo HTResponse.lo HTStream.lo HTTrans.!
!
>!
>lo HTChannl.lo HTInet.lo HTHost.lo HTLocal.lo HTReader.lo HTANSI.lo HTBufWrt.lo HTTChunk.lo HTHInit.lo HTMIMImp.lo HTSChunk.lo HTLib.lo HTLink.lo HTFilter.lo HTUTree.lo HTPEP.lo HTProfil.lo HTMerge.lo HTDemux.lo HTMuxTx.lo HTMuxCh.lo HTTimer.lo HTTrace.lo HTMemLog.lo  /mydir/rx-1.5/lib/librx.a -ldl -lnsl -lsocket -lICE 
>libtool: link: cannot build libtool library `libwww.la' from non-libtool objects: /mydir/rx-1.5/lib/librx.a
>
>It doesn't allow me to link the library librx.a . I installed before other versions of
>libwww without problems. 
>
>Thanks a lot for your help.
>
>Best wishes
>
>John Punin
>
>p.s. I'm using solaris 5.6 
>
>
--
Henrik Frystyk Nielsen,
World Wide Web Consortium
http://www.w3.org/People/Frystyk
Received on Monday, 1 June 1998 19:54:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:27 GMT