W3C home > Mailing lists > Public > www-lib@w3.org > July to September 1995

Problem with libwww on IRIX 5.3

From: James Waldrop <sulam@vrml.arc.org>
Date: Mon, 04 Sep 1995 19:59:08 -0700
Message-Id: <199509050259.TAA13584@vrml.arc.org>
To: www-lib@w3.org

Well, I tried searching the mailing list archive, since I believe this
should be a common problem, but that didn't work, so here I am.

I'm trying to use libwww to, among other things, grab a document from
a remote webserver.  This all seems very simple, but the linker cannot
resolve any of the libwww functions I call.  The archive is built with
ar r libwww.a $(COMMON).o, and seems to be working successfully.  I don't
believe I should be doing anything with lorder or tsort on IRIX, but
perhaps this is incorrect??

Thanks for any help you folks can give me.


Code and results of the compile are included:

/* Simple program to grab a remote URL */

#include <stdio.h>
#include <www/WWWLib.h>

int main(int argc, char **argv) {
    HTRequest *request;

    request = HTRequest_new();
    HTLoadAbsolute("http://www.construct.net", request);
    return 0;

/* EOF */

[vrml] ~/src/httpv : gcc -lwww get_url.c
collect2: ld returned 1 exit status
[vrml] ~/src/httpv : 

James Waldrop				/	    Technical Director
sulam@construct.net		/		    Construct Internet Design
sulam@well.com		/			    http://www.construct.net
Received on Monday, 4 September 1995 23:14:50 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:33:46 UTC