W3C home > Mailing lists > Public > www-jigsaw@w3.org > September to October 2003

Re: COPY and MOVE methods not working in SSL mode

From: Yves Lafon <ylafon@w3.org>
Date: Thu, 30 Oct 2003 10:54:50 +0100 (MET)
To: Ranjan Darbha <nagaranjand@vedams.com>
Cc: www-jigsaw@w3.org
Message-ID: <Pine.GSO.4.58.0310301051170.5648@gnenaghyn.vaevn.se>

On Thu, 30 Oct 2003, Ranjan Darbha wrote:

> Hi all,
>
> Jigsaw-WebDAV is working well in HTTP mode. But, I am facing problems in
> COPY and MOVE methods, while working in HTTPS mode. I configured the
> Jigsaw server to run WebDAV. It is working well with PROPFIND, PUT and
> other methods. But, it is giving a problem when COPY and MOVE methods
> are called. It's giving "500 Internal Server Error".
>
> I observed that when the request processing is done by directly getting
> the information from the client then it is working, but when the request
> processing is done by getting the information from within the server
> then it is not working. For COPY and MOVE methods, the processing is
> done at the server itself unlike the PUT method where the source
> resource is uploaded from a client.

The main issue there is that copy and move are using plain HTTP to access
files instead of HTTPS. I'll look into that, at least for the case where
both collections are on the same server.
If someone have made a SSL enabled HTTP stack based on Jigsaw's and would
contribute it, it would be real nice :)
Thanks,

-- 
Yves Lafon - W3C
"Baroula que barouleras, au tiéu toujou t'entourneras."
Received on Thursday, 30 October 2003 04:54:53 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:36 GMT