W3C home > Mailing lists > Public > www-jigsaw@w3.org > November to December 2003

Re: COPY and MOVE methods not working in SSL mode

From: Ranjan Darbha <nagaranjand@vedams.com>
Date: Tue, 4 Nov 2003 18:11:26 -0600
Message-ID: <000801c3a331$5c397420$6d01a8c0@ranjan>
To: "Yves Lafon" <ylafon@w3.org>
Cc: <www-jigsaw@w3.org>

Hi Yves,

I see a problem making the latest internalCopy method work (when the server
is run on Windows Platform). I think it fails to DELETE a file as part of
MOVE method. While the (internalCopy)COPY is called to create the
destination I think the InputStream is not closed on the source file, that's
why delete operation on source file after the copy method is failed.

[Because, on Windows Platform, whenever a file is accessed using the streams
and the streams are not closed, then deleting the file will not happen.]

thank you,
Ranjan.

----- Original Message -----
From: "Yves Lafon" <ylafon@w3.org>
To: "Ranjan Darbha" <nagaranjand@vedams.com>
Cc: <www-jigsaw@w3.org>
Sent: Thursday, October 30, 2003 2:04 PM
Subject: Re: COPY and MOVE methods not working in SSL mode



On Thu, 30 Oct 2003, Ranjan Darbha wrote:

> Thank you Yves,
>
> It's working.
>
> It will be helpful if you can tell me the classes that have been changed
to
> make this work.

Only org.w3c.jigsaw.webdav.DAVFrame, you can get the diff from [1]

[1]
http://dev.w3.org/cvsweb/java/classes/org/w3c/jigsaw/webdav/DAVFrame.java.di
ff?r1=1.34&r2=1.35&f=h


>
> Thank you,
> Ranjan.
>
>
> ----- Original Message -----
> From: "Yves Lafon" <ylafon@w3.org>
> To: "Ranjan Darbha" <nagaranjand@vedams.com>
> Cc: <www-jigsaw@w3.org>
> Sent: Thursday, October 30, 2003 6:27 AM
> Subject: Re: COPY and MOVE methods not working in SSL mode
>
>
> I did some more coding, can you get the jar located at [1] and tell me if
> it works in you case?
> Thanks,
>
> [1] http://jigsaw.w3.org/Devel/classes-2.2/20031030/
>
> > > > Hi all,
> > > >
> > > > Jigsaw-WebDAV is working well in HTTP mode. But, I am facing
problems
> in
> > > > COPY and MOVE methods, while working in HTTPS mode. I configured the
> > > > Jigsaw server to run WebDAV. It is working well with PROPFIND, PUT
and
> > > > other methods. But, it is giving a problem when COPY and MOVE
methods
> > > > are called. It's giving "500 Internal Server Error".
> > > >
> > > > I observed that when the request processing is done by directly
> getting
> > > > the information from the client then it is working, but when the
> request
> > > > processing is done by getting the information from within the server
> > > > then it is not working. For COPY and MOVE methods, the processing is
> > > > done at the server itself unlike the PUT method where the source
> > > > resource is uploaded from a client.
> > >
> > > The main issue there is that copy and move are using plain HTTP to
> access
> > > files instead of HTTPS. I'll look into that, at least for the case
where
> > > both collections are on the same server.
> > > If someone have made a SSL enabled HTTP stack based on Jigsaw's and
> would
> > > contribute it, it would be real nice :)
> > > Thanks,
> > >
> > > --
> > > Yves Lafon - W3C
> > > "Baroula que barouleras, au tiéu toujou t'entourneras."
> > >
> >
> >
>
> --
> Yves Lafon - W3C
> "Baroula que barouleras, au tiéu toujou t'entourneras."
>

--
Yves Lafon - W3C
"Baroula que barouleras, au tiéu toujou t'entourneras."
Received on Tuesday, 4 November 2003 07:46:27 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:36 GMT