W3C home > Mailing lists > Public > www-jigsaw@w3.org > May to June 2003

Directory names with spaces in the http-server.props file for Jigsaw WebDAV causes problems.

From: Brett Wagner <bwagner@mqsoftware.com>
Date: Fri, 23 May 2003 11:14:06 -0500
Message-ID: <A14F6A96A4696D468FBF4256637CBAA81E14BF@mailservermn.mqsoftware.com>
To: <www-jigsaw@w3.org>

We have run into a problem configuring our Jigsaw WebDAV on a Windows NT/2000 system.  The issue is that we have our Jigsaw WebDAV installed under D:\Program Files\.  This causes problems when we specify paths in http-server.props.  Specifically the following lines:
org.w3c.cvs.path=D\:\\Program Files\\cvs.exe
org.w3c.cvs.root=\:local\:D\:\\Program Files\\cvsroot
org.w3c.cvs.wrapper=D\:\\Program Files\\Jigsaw\\Jigsaw\\bin\\cvs_wrapper.exe
org.w3c.jigsaw.space=D\:\\Program Files\\Jigsaw\\Jigsaw\\WWW

When we run jigsaw and try to put a file via cadaver, both sides hang trying to do the put.  We determined by trial and error that it was the result of the spaces in the directory names in the above lines of http-server-props.  The following is what is generated by jigsaw when we do a put via cadaver:
D:\Program Files\Jigsaw\Jigsaw\bin\cvs_wrapper.exe -directory D:\Program Files\Jigsaw\Jigsaw\WWW D:\Program Files\cvs.exe -q -d :local:D:\Program Files\cvsroot -n update -I ! -l
We tried encompassing the paths in double quotes and that enabled the executables to run, but we needed the -directory option to be double quoted as well which comes from the org.w3c.jigsaw.space variable.  Unfortunately, when we double quoted this variable, the put failed to cause to even cause jigsaw to generate and execute the cvs_wapper.exe line above and gave us the following error on the cadaver side:
dav:/MQSoftware/> put MetaInformation.xml
Uploading MetaInformation.xml to `/MQSoftware/MetaInformation.xml':
Progress: [=============================>] 100.0% of 8590 bytes failed:
415 Unsupported Media Type

We tried replacing the directory name space with %20 and \%20, but to no avail.  Finally, we had to resort to using the 8.3 names used by Microsoft in the following fashion:
org.w3c.cvs.path=D\:\\PROGRA~1\\cvs.exe
org.w3c.cvs.root=\:local\:D\:\\PROGRA~1\\cvsroot
org.w3c.cvs.wrapper=D\:\\PROGRA~1\\Jigsaw\\Jigsaw\\bin\\cvs_wrapper.exe
org.w3c.jigsaw.space=D\:\\PROGRA~1\\Jigsaw\\Jigsaw\\WWW

This worked, but is not the desired solution as we would like this to install this on Unix platforms as well.  Is there some way of entering directory names with spaces into the http-server.props file?

Thanks,
Brett Wagner
Received on Friday, 23 May 2003 12:14:08 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:36 GMT