W3C home > Mailing lists > Public > www-jigsaw@w3.org > November to December 2000

Problems with Proxy and Filter Configuration

From: Marko Werner <werner@informatik.tu-muenchen.de>
Date: Fri, 8 Dec 2000 17:57:25 +0000
To: <www-jigsaw@w3.org>
Message-ID: <EKEDLKDPMMHIBAEMNGBCOEHECAAA.werner@in.tum.de>
Hi!

I've configured Jigsaw as proxy server. First it didn't work but got the
thing running with ProxyExtFrame instead of ProxyFrame configured as frame
for the proxy resource. (Strange!?)

After that I added a org.w3c.jigsaw.filters.DebugFilter to the frame (via
the properties of the proxy) but when I restarting the server it failed
throwing this exception:

Error initializing prop filters:
Coulnd't initialize [org.w3c.jigsaw.filters.DebugFilter]:
org.w3c.jigsaw.filters.DebugFilter
java.lang.ClassCastException: org.w3c.jigsaw.filters.DebugFilter
        at
org.w3c.www.protocol.http.HttpManager.getManager(HttpManager.java:357)
        at
org.w3c.www.protocol.http.HttpManager.getManager(HttpManager.java:449)
        at
org.w3c.jigsaw.proxy.ForwardFrame.registerResource(ForwardFrame.java:424)
        at
org.w3c.jigsaw.proxy.ProxyFrame.registerResource(ProxyFrame.java:401)
        at
org.w3c.tools.resources.FramedResource.initialize(FramedResource.java:703)
        at
org.w3c.tools.resources.AttributeHolder.initialize(AttributeHolder.java:435)
        at
org.w3c.tools.resources.store.ResourceStoreImpl$ResourceIndex.loadResource(R
esourceStoreImpl.java:56)
        at
org.w3c.tools.resources.store.ResourceStoreImpl.loadResource(ResourceStoreIm
pl.java:196)
        at
org.w3c.tools.resources.store.NewReference.lock(NewStoreEntry.java:85)
        at
org.w3c.tools.resources.store.NewStoreEntry.loadResource(NewStoreEntry.java:
255)
        at
org.w3c.tools.resources.store.ResourceStoreManager.loadRootResource(Resource
StoreManager.java:961)
        at org.w3c.jigsaw.http.httpd.loadRoot(httpd.java:827)
        at org.w3c.jigsaw.http.httpd.changeRoot(httpd.java:834)
        at org.w3c.jigsaw.http.httpd.initializeRootResource(httpd.java:863)
        at org.w3c.jigsaw.http.httpd.start(httpd.java:1919)
        at
org.w3c.jigsaw.daemon.ServerHandlerManager.<init>(ServerHandlerManager.java:
280)
        at
org.w3c.jigsaw.daemon.ServerHandlerManager.main(ServerHandlerManager.java:49
1)
        at org.w3c.jigsaw.Main.main(Main.java:15)

Is this a bug or is there anything wrong with my configuration?

Thanks!

Marko
Received on Friday, 8 December 2000 11:58:00 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:34 GMT