W3C home > Mailing lists > Public > www-jigsaw@w3.org > May to June 2000

Re: Redirects from www servers

From: Yves Lafon <ylafon@w3.org>
Date: Thu, 8 Jun 2000 16:01:03 +0200 (MET DST)
To: Niklas Wiberg <e95_nwi@it.kth.se>
cc: www-jigsaw@w3.org
Message-ID: <Pine.GSO.4.21.0006081533370.24920-100000@tarantula.inria.fr>
On Wed, 3 May 2000, Niklas Wiberg wrote:

> Hello,
> I use Jigsaw 2.0.4 as a proxy. When I try to log in to some personal
> pages at yahoo, e.g. edit.my.yahoo.com, I get redirected back to the
> login page when my traffic goes through the proxy. If I log in without
> going through the proxy, I'm logged-in properly...
> It seems as if the yahoo-server responds with a 302 found when the
> request comes from the Jigsaw proxy, but with a 200 OK when the request
> is direct.
> The requests sent to the server (directly and from the proxy) looks
> roughly the same to me, apart from the 'Via' header (which doesn't show
> a fully qualified DNS name, but rather an internal one-word hostname). 
> Can anyone see a particular reason for this behavior from a web server?

Sorry for the delay
Was there some cookie that may have been eaten? I remember that there was
a fix with Set-Cookie, related to that. But it seems to be before 2.0.4,
anyway, try with http://jigsaw.w3.org/Devel/classes-2.0/20000608/ which is
quite close to an upcoming 2.0.5.
Do you have a trace handy? like a text tcpdump of the request sent?
I used my.yahoo.com through the proxy, and it works well...
Regards,

      /\          - Yves Lafon - World Wide Web Consortium - 
  /\ /  \        Architecture Domain - Jigsaw Activity Leader
 /  \    \/\    
/    \   /  \   http://www.w3.org/People/Lafon - ylafon@w3.org    
Received on Thursday, 8 June 2000 10:32:23 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:34 GMT